summaryrefslogtreecommitdiff
path: root/wiretap/Makefile.am
diff options
context:
space:
mode:
authorStig Bjørlykke <stig@bjorlykke.org>2014-04-23 10:50:27 +0200
committerAnders Broman <a.broman58@gmail.com>2014-04-25 04:23:46 +0000
commitbd38b3152d12584b9cd31d0c49706f1cebaa087a (patch)
treedd9ffd4b9f64647e9c683085b0fb73337132a7ab /wiretap/Makefile.am
parent748e0d4221eabab207a350640ce3f526c73afde9 (diff)
downloadwireshark-bd38b3152d12584b9cd31d0c49706f1cebaa087a.tar.gz
Support out-of-source checkapi
Always call $(top_srcdir)/tools/checkAPIs.pl with -sourcedir=$(srcdir) from Makefile.am to allow out-of-source 'make checkapi'. Change-Id: I60d7e0079984a8ededdacf4517a0738486fa7973 Reviewed-on: https://code.wireshark.org/review/1294 Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'wiretap/Makefile.am')
-rw-r--r--wiretap/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/wiretap/Makefile.am b/wiretap/Makefile.am
index c0151c6601..04900bf493 100644
--- a/wiretap/Makefile.am
+++ b/wiretap/Makefile.am
@@ -104,5 +104,7 @@ dumpabi-libwiretap: all abi-descriptor.xml
checkapi:
## 'abort' checking disabled for now pending resolution of existing use of g_assert & g_error
-## $(PERL) ../tools/checkAPIs.pl -g abort -g termoutput $(NONGENERATED_C_FILES) $(GENERATOR_FILES)
- $(PERL) ../tools/checkAPIs.pl -g termoutput -build $(NONGENERATED_C_FILES) $(GENERATOR_FILES)
+## $(PERL) $(top_srcdir)/tools/checkAPIs.pl -g abort -g termoutput \
+ $(PERL) $(top_srcdir)/tools/checkAPIs.pl -g termoutput -build \
+ -sourcedir=$(srcdir) \
+ $(NONGENERATED_C_FILES) $(GENERATOR_FILES)