summaryrefslogtreecommitdiff
path: root/wiretap/configure.in
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2000-10-17 07:30:35 +0000
committerGuy Harris <guy@alum.mit.edu>2000-10-17 07:30:35 +0000
commitfc1ed4cd4b03776364f9a2b3ddcfaee545897ee0 (patch)
tree67d63bfe859ae0bcfef84ce6855c16875a4661bf /wiretap/configure.in
parent81c030d01ae128ed3c0c1bfd6f74e40247622bad (diff)
downloadwireshark-fc1ed4cd4b03776364f9a2b3ddcfaee545897ee0.tar.gz
Do checks for platform-specific compiler flags in the libethereal and
wiretap configure scripts as well as in the main configure script. svn path=/trunk/; revision=2501
Diffstat (limited to 'wiretap/configure.in')
-rw-r--r--wiretap/configure.in29
1 files changed, 28 insertions, 1 deletions
diff --git a/wiretap/configure.in b/wiretap/configure.in
index 1595831551..426879a432 100644
--- a/wiretap/configure.in
+++ b/wiretap/configure.in
@@ -1,4 +1,4 @@
-# $Id: configure.in,v 1.24 2000/10/17 00:09:43 guy Exp $
+# $Id: configure.in,v 1.25 2000/10/17 07:30:35 guy Exp $
dnl
dnl Process this file with autoconf 2.13 or later to produce a
dnl configure script; 2.12 doesn't generate a "configure" script that
@@ -35,6 +35,33 @@ else
AC_MSG_RESULT(no)
fi
+#
+# Add any platform-specific compiler flags needed.
+#
+AC_MSG_CHECKING(for platform-specific compiler flags)
+if test "x$GCC" = x
+then
+ #
+ # Not GCC - assume it's the vendor's compiler.
+ #
+ case "$host_os" in
+ hpux*)
+ #
+ # HP's ANSI C compiler; flags suggested by Jost Martin.
+ # "-Ae" for ANSI C plus extensions such as "long long".
+ # "+O2", for optimization. XXX - works with "-g"?
+ #
+ CFLAGS="-Ae +O2 $CFLAGS"
+ AC_MSG_RESULT(HP ANSI C compiler - added -Ae +O2)
+ ;;
+ *)
+ AC_MSG_RESULT(none needed)
+ ;;
+ esac
+else
+ AC_MSG_RESULT(none needed)
+fi
+
# Checks for glib first, or gtk+ if not present
AM_PATH_GLIB(1.1.0, CFLAGS="$CFLAGS $GLIB_CFLAGS" LIBS="$LIBS $GLIB_LIBS")