summaryrefslogtreecommitdiff
path: root/wsutil/CMakeLists.txt
diff options
context:
space:
mode:
authorDario Lombardo <lomato@gmail.com>2016-09-28 12:01:33 +0200
committerPeter Wu <peter@lekensteyn.nl>2016-09-30 20:12:00 +0000
commit11c10244ef5168a337d88611d61c5ebc88acd29e (patch)
treec1503548a6ae38cb372632d14169a880cc5ae95d /wsutil/CMakeLists.txt
parent534787e402d6aa8b349638f911a2a65b013c6594 (diff)
downloadwireshark-11c10244ef5168a337d88611d61c5ebc88acd29e.tar.gz
wsutil: split libjsmn.
The libjsmn was imported into the tree and enhanced with a new function. This change splits it into the "original" libjsmn and an addictional module wsjsmn that contains the new function. This will make easier to port within the tree future versions of the library. Change-Id: I3f1caa91bee462e0767e5e18d0b6a10f0b1cad32 Reviewed-on: https://code.wireshark.org/review/17963 Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Peter Wu <peter@lekensteyn.nl>
Diffstat (limited to 'wsutil/CMakeLists.txt')
-rw-r--r--wsutil/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/wsutil/CMakeLists.txt b/wsutil/CMakeLists.txt
index 539126df04..438bc42cbb 100644
--- a/wsutil/CMakeLists.txt
+++ b/wsutil/CMakeLists.txt
@@ -69,6 +69,7 @@ set(WSUTIL_COMMON_FILES
type_util.c
unicode-utils.c
ws_mempbrk.c
+ wsjsmn.c
)
set(WSUTIL_FILES ${WSUTIL_COMMON_FILES})
@@ -258,6 +259,8 @@ CHECKAPI(
${WSUTIL_COMMON_FILES}
)
+set_source_files_properties(jsmn.c PROPERTIES COMPILE_DEFINITIONS "JSMN_STRICT")
+
#
# Editor modelines - http://www.wireshark.org/tools/modelines.html
#