summaryrefslogtreecommitdiff
path: root/wsutil/CMakeLists.txt
diff options
context:
space:
mode:
authorDario Lombardo <lomato@gmail.com>2016-08-24 16:48:39 +0200
committerDario Lombardo <lomato@gmail.com>2016-08-26 21:04:40 +0000
commit139170c6c6b29cf9c1eba9bbcacfbffdf447e2ef (patch)
tree7a9be7b596f947e980e445caa3b321c6f7d5d6e3 /wsutil/CMakeLists.txt
parentd0565ad22b14eae64776fb7cf04377e902380ef9 (diff)
downloadwireshark-139170c6c6b29cf9c1eba9bbcacfbffdf447e2ef.tar.gz
wsutil: add enumeration of local ip addresses in Windows.
Routine used by ssh-based extcaps. Change-Id: I06d8e1e1444cd03a0508dc0c7cb91d340a451c58 Reviewed-on: https://code.wireshark.org/review/17308 Petri-Dish: Dario Lombardo <lomato@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Roland Knall <rknall@gmail.com> Reviewed-by: João Valverde <j@v6e.pt> Reviewed-by: Dario Lombardo <lomato@gmail.com>
Diffstat (limited to 'wsutil/CMakeLists.txt')
-rw-r--r--wsutil/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/wsutil/CMakeLists.txt b/wsutil/CMakeLists.txt
index cccf86a62e..15d64a34ed 100644
--- a/wsutil/CMakeLists.txt
+++ b/wsutil/CMakeLists.txt
@@ -180,7 +180,7 @@ set(wsutil_LIBS
${WIN_WSOCK32_LIBRARY}
)
IF(WIN32)
- set(wsutil_LIBS ${wsutil_LIBS} "ws2_32.lib")
+ set(wsutil_LIBS ${wsutil_LIBS} "iphlpapi.lib" "ws2_32.lib")
ENDIF(WIN32)
set(CLEAN_FILES