summaryrefslogtreecommitdiff
path: root/wsutil/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2014-12-22 21:03:46 -0800
committerGuy Harris <guy@alum.mit.edu>2014-12-23 05:04:17 +0000
commit1b37f4c5ef01eaa1fe5724ced0954ceba27fe5f2 (patch)
tree9a11cc25488081aed05403be15c9579c37ffaf79 /wsutil/CMakeLists.txt
parent4009231b2c21a90638d5eebd5e97bda82ff99862 (diff)
downloadwireshark-1b37f4c5ef01eaa1fe5724ced0954ceba27fe5f2.tar.gz
Cmake: check for popcount, and build it from wsutil/popcount.c if missing.
Change-Id: Id646a9f0b1fc6acafa99a78725e3f0ec8a48c170 Reviewed-on: https://code.wireshark.org/review/6006 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'wsutil/CMakeLists.txt')
-rw-r--r--wsutil/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/wsutil/CMakeLists.txt b/wsutil/CMakeLists.txt
index a7f0663ead..05b32815c1 100644
--- a/wsutil/CMakeLists.txt
+++ b/wsutil/CMakeLists.txt
@@ -38,6 +38,12 @@ if(HAVE_SSE4_2)
)
endif()
+if(NOT HAVE_POPCOUNT)
+ set( WSUTIL_POPCOUNT_FILES
+ popcount.c
+ )
+endif()
+
set(WSUTIL_FILES
adler32.c
aes.c
@@ -89,6 +95,7 @@ set(WSUTIL_FILES
ws_version_info.c
${WSUTIL_PLATFORM_FILES}
${WSUTIL_SSE42_FILES}
+ ${WSUTIL_POPCOUNT_FILES}
)
if(APPLE)