summaryrefslogtreecommitdiff
path: root/wsutil/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2014-08-08 10:10:36 -0700
committerGuy Harris <guy@alum.mit.edu>2014-08-08 17:11:03 +0000
commit9b9005eb94d9c89a02d93e8dda0c19b8e2d1a6d7 (patch)
treef5a9c6f552bec38fff10c479f6fd1a1755b80af9 /wsutil/CMakeLists.txt
parent57927c8a56ad132c3a9ca507bdb1584043a94abb (diff)
downloadwireshark-9b9005eb94d9c89a02d93e8dda0c19b8e2d1a6d7.tar.gz
The DRM DCP CRC-16 is the same as the X.25 CRC-16.
So just use crc16_x25_ccitt_tvb(), which goes a byte at a time rather than a bit at a time, and which takes a tvbuff rather than requiring you to call tvb_get_ptr(). It also doesn't 1's-complement the result, so we can compare it against the 0x1D0F in ETSI TS 102 821 V1.4.1 (2012-10) rather than against a 1's-complement version, 0xE2F0. Change-Id: Ia513f851f0a8ff1e7853278ddf3618c532fb2aba Reviewed-on: https://code.wireshark.org/review/3507 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'wsutil/CMakeLists.txt')
-rw-r--r--wsutil/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/wsutil/CMakeLists.txt b/wsutil/CMakeLists.txt
index 9efb7b26a4..0a3c1a969a 100644
--- a/wsutil/CMakeLists.txt
+++ b/wsutil/CMakeLists.txt
@@ -60,7 +60,6 @@ set(WSUTIL_FILES
crc7.c
crc8.c
crc11.c
- crcdrm.c
des.c
eax.c
filesystem.c