summaryrefslogtreecommitdiff
path: root/wsutil/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2015-01-20 20:39:09 -0800
committerGuy Harris <guy@alum.mit.edu>2015-01-21 04:39:33 +0000
commitdb6f7339f712ba3ac4662a7e554b851afc7df6aa (patch)
tree0b2f5b65647156c370e859e54414e515119d5703 /wsutil/CMakeLists.txt
parent41cbbc2f77dbe8f36ff37a607b402f488dc373ea (diff)
downloadwireshark-db6f7339f712ba3ac4662a7e554b851afc7df6aa.tar.gz
Always set the COMPILE_FLAGS property, so we can always fetch it.
If we aren't adding -Werror, just set it to a null string, so when we fetch it to add the SSE 4.2 flag to it for ws_mempbrk_sse42.c, it doesn't fail. Change-Id: I53858130c025e094ed8d0d975451961506fb1a39 Reviewed-on: https://code.wireshark.org/review/6704 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'wsutil/CMakeLists.txt')
-rw-r--r--wsutil/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/wsutil/CMakeLists.txt b/wsutil/CMakeLists.txt
index a467f5f67b..0a8ed63acc 100644
--- a/wsutil/CMakeLists.txt
+++ b/wsutil/CMakeLists.txt
@@ -166,6 +166,16 @@ if (WERROR)
PROPERTIES
COMPILE_FLAGS -Werror
)
+else()
+ #
+ # Set the property to an empty string, so that if we try
+ # to get it below, it succeeds.
+ #
+ set_source_files_properties(
+ ${CLEAN_FILES}
+ PROPERTIES
+ COMPILE_FLAGS ""
+ )
endif()
if (HAVE_SSE4_2)
get_source_file_property(