summaryrefslogtreecommitdiff
path: root/wsutil/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2015-11-25 05:46:40 +0000
committerPeter Wu <peter@lekensteyn.nl>2015-11-29 21:54:34 +0000
commite639a13d11bcdb604482d924ebecb1c5bce97d50 (patch)
treee7b5d4dcdb1e9356414399c17bd6a057b5d5139d /wsutil/CMakeLists.txt
parent2932596b65c36a63e79ab85d3349d404a1e16b37 (diff)
downloadwireshark-e639a13d11bcdb604482d924ebecb1c5bce97d50.tar.gz
cfutils.c: Fix ISO C forbids an empty translation unit [-Wpedantic]
Change-Id: Iac9384e63a4e946c73832103f8d6949f0187fa38 Reviewed-on: https://code.wireshark.org/review/12147 Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Peter Wu <peter@lekensteyn.nl>
Diffstat (limited to 'wsutil/CMakeLists.txt')
-rw-r--r--wsutil/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/wsutil/CMakeLists.txt b/wsutil/CMakeLists.txt
index d8870fe041..fd3eb6a745 100644
--- a/wsutil/CMakeLists.txt
+++ b/wsutil/CMakeLists.txt
@@ -36,7 +36,6 @@ set(WSUTIL_FILES
base64.c
bitswap.c
buffer.c
- cfutils.c
clopts_common.c
cmdarg_err.c
copyright_info.c
@@ -78,6 +77,10 @@ set(WSUTIL_FILES
${WSUTIL_PLATFORM_FILES}
)
+if(HAVE_OS_X_FRAMEWORKS)
+ set(WSUTIL_FILES ${WSUTIL_FILES} cfutils.c)
+endif()
+
#
# XXX - we're assuming MSVC doesn't require a flag to enable SSE 4.2
# support, and that, if the compiler supports a flag for SSE 4.2