summaryrefslogtreecommitdiff
path: root/wsutil/CMakeLists.txt
diff options
context:
space:
mode:
authorerikdejong <erikdejong@gmail.com>2017-03-06 22:01:39 +0100
committerPeter Wu <peter@lekensteyn.nl>2017-03-10 02:54:51 +0000
commitfe285c640b6279fdb9920bb79b0494ac87cb0e32 (patch)
tree85d71f80358f486494368fab9fde765562363eb9 /wsutil/CMakeLists.txt
parent9e0251f2187388ce03b4afde91df2528e313afd8 (diff)
downloadwireshark-fe285c640b6279fdb9920bb79b0494ac87cb0e32.tar.gz
Replace aes.c and des.c by Libgcrypt
Follow-up of https://code.wireshark.org/review/20095 Rewritten functions: - crypt_des_ecb crypt_des_ecb verified against previous crypt_des_ecb implementation with 4294967295 random keys and input buffers from /dev/random as I cannot find a suitable pcap which uses DES Change-Id: I21ec2572451e0ded4299ffadd8dd687817bc6318 Reviewed-on: https://code.wireshark.org/review/20429 Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Peter Wu <peter@lekensteyn.nl>
Diffstat (limited to 'wsutil/CMakeLists.txt')
-rw-r--r--wsutil/CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/wsutil/CMakeLists.txt b/wsutil/CMakeLists.txt
index e915e915e5..9982f0dd0b 100644
--- a/wsutil/CMakeLists.txt
+++ b/wsutil/CMakeLists.txt
@@ -23,7 +23,6 @@ include(UseABICheck)
set(WSUTIL_COMMON_FILES
adler32.c
- aes.c
airpdcap_wep.c
base32.c
base64.c
@@ -41,7 +40,6 @@ set(WSUTIL_COMMON_FILES
crc7.c
crc8.c
crc11.c
- des.c
eax.c
filesystem.c
frequency-utils.c