summaryrefslogtreecommitdiff
path: root/wsutil/Makefile.am
diff options
context:
space:
mode:
authorStephen Fisher <sfisher@sdf.org>2014-12-22 13:50:10 -0700
committerStephen Fisher <sfisher@sdf.org>2014-12-23 00:22:23 +0000
commit3d62d2c396aa016d97f788205978f4fdba2d4d4b (patch)
tree161f97d511c7449b0caf17ab87edef4b0280a573 /wsutil/Makefile.am
parent59b4ab53fcf08db3daa7461b463ca47e83e55079 (diff)
downloadwireshark-3d62d2c396aa016d97f788205978f4fdba2d4d4b.tar.gz
Move popcount() to an optionally built part of wsutil for systems that
provide their own popcount(). Change-Id: Ic26f3b50cf0bd2b4af0d42e9c27488ebbac1ab33 Reviewed-on: https://code.wireshark.org/review/5998 Petri-Dish: Stephen Fisher <sfisher@sdf.org> Reviewed-by: Stephen Fisher <sfisher@sdf.org>
Diffstat (limited to 'wsutil/Makefile.am')
-rw-r--r--wsutil/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/wsutil/Makefile.am b/wsutil/Makefile.am
index 8401e45b08..8e160fd969 100644
--- a/wsutil/Makefile.am
+++ b/wsutil/Makefile.am
@@ -36,6 +36,7 @@ wsutil_optional_objects = \
@INET_ATON_LO@ \
@INET_NTOP_LO@ \
@INET_PTON_LO@ \
+ @POPCOUNT_LO@ \
@STRPTIME_LO@
if SSE42_SUPPORTED
@@ -79,6 +80,8 @@ EXTRA_libwsutil_la_SOURCES= \
inet_ntop.c \
inet_pton.c \
inet_v6defs.h \
+ popcount.c \
+ popcount.h \
strptime.c \
strptime.h \
wsgetopt.c \