summaryrefslogtreecommitdiff
path: root/wsutil/Makefile.am
diff options
context:
space:
mode:
authorAhmad Fatoum <ahmad@a3f.at>2017-04-26 07:33:25 +0200
committerMichael Mann <mmann78@netscape.net>2017-06-05 23:43:03 +0000
commit502cc61711173273ffb8be2cf895f5e79c3b47bc (patch)
tree53db680580f3ca6a56461908330b9a30218a1449 /wsutil/Makefile.am
parent1b228df643121ab2fabde34226701b9cd92401be (diff)
downloadwireshark-502cc61711173273ffb8be2cf895f5e79c3b47bc.tar.gz
Move RSA key loading and decryption functions to wsutil
Loading PEM and PKCS#11 keys was being done in static functions in packet-ssl-utils.c. These were moved to wsutil, with prototypes in a new <wsutil/rsa.h> header. This adds gnutls as optional dependency to wsutil. The RSA decryption helper was also moved and is now provided in <wsutil/wsgcrypt.h>. This allows more dissectors to access this functionality. Change-Id: I6cfbbf5203f2881c82bad721747834ccd76e2033 Reviewed-on: https://code.wireshark.org/review/21941 Reviewed-by: Peter Wu <peter@lekensteyn.nl> Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Michael Mann <mmann78@netscape.net>
Diffstat (limited to 'wsutil/Makefile.am')
-rw-r--r--wsutil/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/wsutil/Makefile.am b/wsutil/Makefile.am
index 28f04c5be0..cb409f7f4d 100644
--- a/wsutil/Makefile.am
+++ b/wsutil/Makefile.am
@@ -26,7 +26,8 @@ AM_CPPFLAGS = $(INCLUDEDIRS) $(WS_CPPFLAGS) -DWS_BUILD_DLL \
-DEXTCAP_DIR=\"$(extcapdir)\" \
-DPLUGIN_INSTALL_DIR=\"$(plugindir)\" \
-DJSMN_STRICT \
- $(GLIB_CFLAGS) $(LIBGCRYPT_CFLAGS)
+ $(GLIB_CFLAGS) $(LIBGCRYPT_CFLAGS) \
+ $(LIBGNUTLS_CFLAGS)
# Optional headers for ABI checking
wsutil_optional_abi_includes =
@@ -144,6 +145,7 @@ libwsutil_la_SOURCES = \
plugins.c \
privileges.c \
report_message.c \
+ rsa.c \
sober128.c \
str_util.c \
strtoi.c \
@@ -174,6 +176,7 @@ libwsutil_la_LIBADD = \
@COREFOUNDATION_FRAMEWORKS@ \
@GLIB_LIBS@ \
@LIBGCRYPT_LIBS@ \
+ @LIBGNUTLS_LIBS@ \
$(wsutil_optional_objects)
EXTRA_libwsutil_la_DEPENDENCIES = \
@@ -195,6 +198,7 @@ EXTRA_DIST = \
inet_pton.c \
popcount.c \
popcount.h \
+ rsa.h \
strptime.c \
strptime.h \
win32-utils.c \