summaryrefslogtreecommitdiff
path: root/wsutil/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2017-01-25 22:20:07 -0800
committerGuy Harris <guy@alum.mit.edu>2017-01-26 07:00:06 +0000
commit5fbcfd632a7446da946a8b1e27004a401b8d74f3 (patch)
tree49742c1657f00bda14b72d7f9e9bec12d263d931 /wsutil/Makefile.am
parent1165dfc8f6b2feead7c989508f38c83f788b5afb (diff)
downloadwireshark-5fbcfd632a7446da946a8b1e27004a401b8d74f3.tar.gz
Clean up some UN*X-vs-Windows socket issues.
Have a wsutil/socket.h file, for inclusion by everything that uses sockets, that contains the UN*X-vs-Windows #includes and #defines to hide some UN*X-sockets vs. Winsock API differences. That stuff mostly comes from from extcap/extcap-base.h; have that file just include wsutil/socket.h rather than defining that stuff itself. Include it in sharkd_daemon.c. Use socklen_t for the size of things to pass to bind() as the last argument; wsutil/socket.h defines it as int on Windows. Ignore sharkd in Git. Change-Id: I3f2171b7aa613717f52305f62bfd7d43e0172dc6 Reviewed-on: https://code.wireshark.org/review/19796 Petri-Dish: Guy Harris <guy@alum.mit.edu> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'wsutil/Makefile.am')
-rw-r--r--wsutil/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/wsutil/Makefile.am b/wsutil/Makefile.am
index a8642d4e10..76b968b66b 100644
--- a/wsutil/Makefile.am
+++ b/wsutil/Makefile.am
@@ -83,6 +83,7 @@ libwsutil_nonrepl_INCLUDES = \
sha2.h \
sign_ext.h \
sober128.h \
+ socket.h \
str_util.h \
strnatcmp.h \
strtoi.h \