summaryrefslogtreecommitdiff
path: root/wsutil/Makefile.am
diff options
context:
space:
mode:
authorDario Lombardo <lomato@gmail.com>2016-08-30 17:52:54 +0200
committerDario Lombardo <lomato@gmail.com>2016-09-05 09:54:12 +0000
commitba981aced8c64ff405cd42b071264e2d9791444a (patch)
tree1abca00c094469dba7d158f962d34a21e1124cbf /wsutil/Makefile.am
parent87519e4c06260f78ecd55defb86bb20c3f4d7697 (diff)
downloadwireshark-ba981aced8c64ff405cd42b071264e2d9791444a.tar.gz
wsutil: add string to integer conversion utilities.
In the current code many functions have been used for convertion (strtol, atoi, g_ascii_strtoll, etc). Those utilities want to be the only, shared, way to convert integers. Change-Id: I22ba1bf54e144e73a4728612a4437de5a2d339e2 Reviewed-on: https://code.wireshark.org/review/17414 Petri-Dish: Dario Lombardo <lomato@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Peter Wu <peter@lekensteyn.nl> Reviewed-by: Roland Knall <rknall@gmail.com> Reviewed-by: Dario Lombardo <lomato@gmail.com>
Diffstat (limited to 'wsutil/Makefile.am')
-rw-r--r--wsutil/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/wsutil/Makefile.am b/wsutil/Makefile.am
index 2cedf9ddbb..1fb0cc9854 100644
--- a/wsutil/Makefile.am
+++ b/wsutil/Makefile.am
@@ -82,6 +82,7 @@ libwsutil_nonrepl_INCLUDES = \
sober128.h \
str_util.h \
strnatcmp.h \
+ strtoi.h \
tempfile.h \
time_util.h \
type_util.h \
@@ -150,6 +151,7 @@ libwsutil_la_SOURCES = \
sha2.c \
sober128.c \
str_util.c \
+ strtoi.c \
strnatcmp.c \
tempfile.c \
time_util.c \