summaryrefslogtreecommitdiff
path: root/wsutil/Makefile.am
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2015-11-25 05:46:40 +0000
committerPeter Wu <peter@lekensteyn.nl>2015-11-29 21:54:34 +0000
commite639a13d11bcdb604482d924ebecb1c5bce97d50 (patch)
treee7b5d4dcdb1e9356414399c17bd6a057b5d5139d /wsutil/Makefile.am
parent2932596b65c36a63e79ab85d3349d404a1e16b37 (diff)
downloadwireshark-e639a13d11bcdb604482d924ebecb1c5bce97d50.tar.gz
cfutils.c: Fix ISO C forbids an empty translation unit [-Wpedantic]
Change-Id: Iac9384e63a4e946c73832103f8d6949f0187fa38 Reviewed-on: https://code.wireshark.org/review/12147 Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Peter Wu <peter@lekensteyn.nl>
Diffstat (limited to 'wsutil/Makefile.am')
-rw-r--r--wsutil/Makefile.am24
1 files changed, 19 insertions, 5 deletions
diff --git a/wsutil/Makefile.am b/wsutil/Makefile.am
index 8e160fd969..e05e29c87a 100644
--- a/wsutil/Makefile.am
+++ b/wsutil/Makefile.am
@@ -23,6 +23,10 @@ ACLOCAL_AMFLAGS = `../aclocal-flags`
# Optional headers for ABI checking
wsutil_optional_abi_includes =
+if HAVE_OS_X_FRAMEWORKS
+wsutil_optional_abi_includes += cfutils.h
+endif
+
# Header files for functions in libwsutil's ABI on this platform.
libwsutil_abi_INCLUDES = \
$(libwsutil_nonrepl_INCLUDES) \
@@ -63,7 +67,15 @@ AM_CPPFLAGS = -I$(srcdir)/.. \
$(LIBGCRYPT_CFLAGS) \
-DTOP_SRCDIR=\"$(abs_top_srcdir)\"
-libwsutil_la_SOURCES = \
+LIBWSUTIL_SRC = $(LIBWSUTIL_COMMON_SRC)
+LIBWSUTIL_INCLUDES = $(LIBWSUTIL_COMMON_INCLUDES)
+
+if HAVE_OS_X_FRAMEWORKS
+LIBWSUTIL_SRC += cfutils.c
+LIBWSUTIL_INCLUDES += cfutils.h
+endif
+
+libwsutil_la_SOURCES = \
$(LIBWSUTIL_SRC) \
$(LIBWSUTIL_INCLUDES)
@@ -72,7 +84,7 @@ libwsutil_sse42_la_SOURCES = \
libwsutil_sse42_la_CFLAGS = $(AM_CFLAGS) @CFLAGS_SSE42@
-EXTRA_libwsutil_la_SOURCES= \
+EXTRA_libwsutil_la_SOURCES = \
floorl.c \
floorl.h \
inet_aton.c \
@@ -88,16 +100,18 @@ EXTRA_libwsutil_la_SOURCES= \
wsgetopt.h \
wsgetopt_int.h
-libwsutil_la_DEPENDENCIES= \
+libwsutil_la_DEPENDENCIES = \
$(wsutil_optional_objects)
-libwsutil_la_LIBADD = \
+libwsutil_la_LIBADD = \
@COREFOUNDATION_FRAMEWORKS@ \
@GLIB_LIBS@ \
@LIBGCRYPT_LIBS@ \
$(wsutil_optional_objects)
-EXTRA_DIST = \
+EXTRA_DIST = \
+ cfutils.c \
+ cfutils.h \
CMakeLists.txt \
Makefile.common \
Makefile.nmake \