summaryrefslogtreecommitdiff
path: root/wsutil/Makefile.am
diff options
context:
space:
mode:
authorerikdejong <erikdejong@gmail.com>2017-03-06 22:01:39 +0100
committerPeter Wu <peter@lekensteyn.nl>2017-03-10 02:54:51 +0000
commitfe285c640b6279fdb9920bb79b0494ac87cb0e32 (patch)
tree85d71f80358f486494368fab9fde765562363eb9 /wsutil/Makefile.am
parent9e0251f2187388ce03b4afde91df2528e313afd8 (diff)
downloadwireshark-fe285c640b6279fdb9920bb79b0494ac87cb0e32.tar.gz
Replace aes.c and des.c by Libgcrypt
Follow-up of https://code.wireshark.org/review/20095 Rewritten functions: - crypt_des_ecb crypt_des_ecb verified against previous crypt_des_ecb implementation with 4294967295 random keys and input buffers from /dev/random as I cannot find a suitable pcap which uses DES Change-Id: I21ec2572451e0ded4299ffadd8dd687817bc6318 Reviewed-on: https://code.wireshark.org/review/20429 Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Peter Wu <peter@lekensteyn.nl>
Diffstat (limited to 'wsutil/Makefile.am')
-rw-r--r--wsutil/Makefile.am4
1 files changed, 0 insertions, 4 deletions
diff --git a/wsutil/Makefile.am b/wsutil/Makefile.am
index e01840f81d..08af239524 100644
--- a/wsutil/Makefile.am
+++ b/wsutil/Makefile.am
@@ -39,7 +39,6 @@ endif
# present in the APIs/ABIs of some, but not all, targets.
libwsutil_nonrepl_INCLUDES = \
adler32.h \
- aes.h \
base32.h \
base64.h \
bits_count_ones.h \
@@ -59,7 +58,6 @@ libwsutil_nonrepl_INCLUDES = \
crc16.h \
crc16-plain.h \
crc32.h \
- des.h \
eax.h \
filesystem.h \
frequency-utils.h \
@@ -114,7 +112,6 @@ lib_LTLIBRARIES = libwsutil.la
libwsutil_la_SOURCES = \
$(libwsutil_nonrepl_INCLUDES) \
adler32.c \
- aes.c \
airpdcap_wep.c \
base32.c \
base64.c \
@@ -133,7 +130,6 @@ libwsutil_la_SOURCES = \
crc16.c \
crc16-plain.c \
crc32.c \
- des.c \
eax.c \
filesystem.c \
frequency-utils.c \