summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 75d001162d..92b2df5e31 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1240,6 +1240,15 @@ if(ENABLE_PLUGINS)
plugins/wimaxmacphy
${CUSTOM_PLUGIN_SRC_DIR}
)
+
+ # Build demo plugin, only if asked explicitly
+ if(ENABLE_PLUGIN_IFDEMO)
+ set(PLUGIN_SRC_DIRS
+ ${PLUGIN_SRC_DIRS}
+ plugins/pluginifdemo
+ )
+ endif()
+
# It seems this stuff doesn't build with autofoo either...
# if(YAPP_FOUND)
# set(PLUGIN_SRC_DIRS