summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 10f31e7f72..497f239675 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -616,6 +616,18 @@ if(ENABLE_ASAN)
endif()
endif()
+if(ENABLE_UBSAN)
+ set(CMAKE_REQUIRED_LIBRARIES "-fsanitize=undefined")
+ check_c_compiler_flag(-fsanitize=undefined C__fsanitize_undefined_VALID)
+ check_cxx_compiler_flag(-fsanitize=undefined CXX__fsanitize_undefined_VALID)
+ set(CMAKE_REQUIRED_LIBRARIES "")
+ if(NOT C__fsanitize_undefined_VALID OR NOT CXX__fsanitize_undefined_VALID)
+ message(FATAL_ERROR "ENABLE_UBSAN was requested, but not supported!")
+ endif()
+ set(CMAKE_C_FLAGS "-fsanitize=undefined ${CMAKE_C_FLAGS}")
+ set(CMAKE_CXX_FLAGS "-fsanitize=undefined ${CMAKE_CXX_FLAGS}")
+endif()
+
set(WERROR_COMMON_FLAGS "")
set(NO_ERROR_DEPRECATED_DECLARATIONS_COMPILE_FLAGS "")
if(NOT DISABLE_WERROR AND NOT ENABLE_EXTRA_COMPILER_WARNINGS)