summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 048b4f925c..2991099b1f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -943,6 +943,7 @@ if(BUILD_mergecap)
set(mergecap_LIBS
wiretap
${ZLIB_LIBRARIES}
+ ${CMAKE_DL_LIBS}
)
set(mergecap_FILES
mergecap.c
@@ -960,6 +961,7 @@ if(BUILD_reordercap)
set(reordercap_LIBS
wiretap
${ZLIB_LIBRARIES}
+ ${CMAKE_DL_LIBS}
)
set(reordercap_FILES
reordercap.c
@@ -979,6 +981,7 @@ if(BUILD_capinfos)
wsutil
${ZLIB_LIBRARIES}
${GCRYPT_LIBRARIES}
+ ${CMAKE_DL_LIBS}
)
set(capinfos_FILES
capinfos.c
@@ -995,6 +998,7 @@ if(BUILD_editcap)
set(editcap_LIBS
wiretap
${ZLIB_LIBRARIES}
+ ${CMAKE_DL_LIBS}
)
set(editcap_FILES
editcap.c