summaryrefslogtreecommitdiff
path: root/asn1/cmp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'asn1/cmp/CMakeLists.txt')
-rw-r--r--asn1/cmp/CMakeLists.txt33
1 files changed, 33 insertions, 0 deletions
diff --git a/asn1/cmp/CMakeLists.txt b/asn1/cmp/CMakeLists.txt
index 1fc4448aed..c8ffbd3ceb 100644
--- a/asn1/cmp/CMakeLists.txt
+++ b/asn1/cmp/CMakeLists.txt
@@ -21,3 +21,36 @@
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
#
+set( PROTOCOL_NAME cmp )
+
+set( PROTO_OPT )
+
+set( EXT_ASN_FILE_LIST
+)
+
+set( ASN_FILE_LIST
+ CMP.asn
+)
+
+set( EXTRA_DIST
+ ${ASN_FILE_LIST}
+ packet-${PROTOCOL_NAME}-template.c
+ packet-${PROTOCOL_NAME}-template.h
+ ${PROTOCOL_NAME}.cnf
+)
+
+set( SRC_FILES
+ ${EXTRA_DIST}
+ ${EXT_ASN_FILE_LIST}
+)
+
+set( A2W_FLAGS -b )
+
+set( EXTRA_CNF
+ ../pkix1explicit/pkix1explicit_exp.cnf
+ ../pkix1implicit/pkix1implicit_exp.cnf
+ crmf-exp.cnf
+)
+
+ASN2WRS()
+