summaryrefslogtreecommitdiff
path: root/asn1/isdn-sup/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'asn1/isdn-sup/CMakeLists.txt')
-rw-r--r--asn1/isdn-sup/CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/asn1/isdn-sup/CMakeLists.txt b/asn1/isdn-sup/CMakeLists.txt
index 1fc4448aed..e2d0dabe78 100644
--- a/asn1/isdn-sup/CMakeLists.txt
+++ b/asn1/isdn-sup/CMakeLists.txt
@@ -21,3 +21,43 @@
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
#
+set( PROTOCOL_NAME isdn-sup )
+
+set( PROTO_OPT )
+
+set( EXPORT_FILES
+ ${PROTOCOL_NAME}-exp.cnf
+)
+
+set( EXT_ASN_FILE_LIST
+)
+
+set( ASN_FILE_LIST
+ Addressing-Data-Elements.asn
+ Basic-Service-Elements.asn
+ Embedded-Q931-Types.asn
+ General-Errors.asn
+ Advice-of-Charge-Operations.asn
+ Closed-User-Group-Service-Operations.asn
+ Conference-Add-On-Operations.asn
+ Diversion-Operations.asn
+ MCID-Operations.asn
+ User-To-User-Signalling-Operations.asn
+ Freephone-Operations.asn
+)
+
+set( EXTRA_DIST
+ ${ASN_FILE_LIST}
+ packet-${PROTOCOL_NAME}-template.c
+ ${PROTOCOL_NAME}.cnf
+)
+
+set( SRC_FILES
+ ${EXTRA_DIST}
+ ${EXT_ASN_FILE_LIST}
+)
+
+set( A2W_FLAGS -b -k )
+
+ASN2WRS()
+