summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 5 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index fa8a4c220b..4527988511 100644
--- a/configure.ac
+++ b/configure.ac
@@ -69,10 +69,12 @@ AC_CONFIG_LIBOBJ_DIR([wsutil])
#
# Checks for programs used in the main build process.
#
-AC_PROG_CC_STDC
-if test "$ac_cv_prog_cc_stdc" = "no"
+# See doc/README.developer for allowed C99 features
+#
+AC_PROG_CC_C99
+if test "$ac_cv_prog_cc_c99" = "no"
then
- AC_MSG_ERROR([The C compiler does not support standard C])
+ AC_MSG_ERROR([The C compiler does not support C99])
fi
AC_PROG_CPP
@@ -690,9 +692,6 @@ then
fi
fi
-#Clang only
-AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wc99-extensions, C)
-
#
# Try to add some additional checks to CFLAGS.
# These are not enabled by default, because the warnings they produce