summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 166c507bbd..5d8673530e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -748,6 +748,10 @@ AC_ARG_ENABLE(extra-compiler-warnings,
# never enable this one with -Werror.
#
AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wbad-function-cast, C)
+
+ # Works only with GCC 7
+ AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wduplicated-branches)
+
fi
])