summaryrefslogtreecommitdiff
path: root/epan/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'epan/Makefile.am')
-rw-r--r--epan/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/epan/Makefile.am b/epan/Makefile.am
index fe5519064a..5d12aeeac1 100644
--- a/epan/Makefile.am
+++ b/epan/Makefile.am
@@ -2,7 +2,7 @@
# Automake file for the EPAN library
# (Ethereal Protocol ANalyzer Library)
#
-# $Id: Makefile.am,v 1.9 2000/10/14 04:31:25 gram Exp $
+# $Id: Makefile.am,v 1.10 2000/10/16 23:17:39 guy Exp $
#
# Ethereal - Network traffic analyzer
# By Gerald Combs <gerald@zing.org>
@@ -30,8 +30,11 @@ YFLAGS=-d -p dfilter_
# EPAN will eventually be a shared library. While I move source code around,
# however, it is an archive library.
+ACLOCAL_AMFLAGS = `../aclocal-flags`
+
noinst_LIBRARIES = libethereal.a
+INCLUDES = -I$(srcdir)/..
libethereal_a_SOURCES = \
conversation.c \
@@ -82,6 +85,12 @@ CLEANFILES = \
libethereal.a \
*~
+#
+# Add the object files for missing routines, if any.
+#
+libethereal_a_LIBADD = @INET_ATON_O@ @INET_PTON_O@ @INET_NTOP_O@
+libethereal_a_DEPENDENCIES = @INET_ATON_O@ @INET_PTON_O@ @INET_NTOP_O@
+
dfilter-scanner.c : dfilter-scanner.l
$(LEX) -Pdfilter_ -odfilter-scanner.c $(srcdir)/dfilter-scanner.l