summaryrefslogtreecommitdiff
path: root/epan/compress/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'epan/compress/Makefile.am')
-rw-r--r--epan/compress/Makefile.am18
1 files changed, 8 insertions, 10 deletions
diff --git a/epan/compress/Makefile.am b/epan/compress/Makefile.am
index 6105061ca7..b196c5b238 100644
--- a/epan/compress/Makefile.am
+++ b/epan/compress/Makefile.am
@@ -19,13 +19,18 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-include Makefile.common
include $(top_srcdir)/Makefile.am.inc
AM_CPPFLAGS = $(INCLUDEDIRS) $(WS_CPPFLAGS) $(GLIB_CFLAGS)
noinst_LTLIBRARIES = liblzxpress.la
+liblzxpress_la_SOURCES = \
+ lzxpress.c \
+ lzxpress.h
+
+EXTRA_DIST =
+
CLEANFILES = \
liblzxpress.a \
liblzxpress.la \
@@ -33,16 +38,9 @@ CLEANFILES = \
DISTCLEANFILES =
-MAINTAINERCLEANFILES = \
+MAINTAINERCLEANFILES = \
Makefile.in
-liblzxpress_la_SOURCES = \
- $(LIBLZXPRESS_SRC) \
- $(LIBLZXPRESS_INCLUDES)
-
-EXTRA_DIST = \
- Makefile.common
-
checkapi:
$(PERL) ../../tools/checkAPIs.pl -g termoutput -build \
- $(LIBLZXPRESS_SRC)
+ $(liblzxpress_la_SOURCES)