summaryrefslogtreecommitdiff
path: root/epan/dissectors/asn1/h501/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'epan/dissectors/asn1/h501/Makefile.am')
-rw-r--r--epan/dissectors/asn1/h501/Makefile.am32
1 files changed, 29 insertions, 3 deletions
diff --git a/epan/dissectors/asn1/h501/Makefile.am b/epan/dissectors/asn1/h501/Makefile.am
index 11932c53a4..d3b183b4e5 100644
--- a/epan/dissectors/asn1/h501/Makefile.am
+++ b/epan/dissectors/asn1/h501/Makefile.am
@@ -16,7 +16,33 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-
-include ../Makefile.preinc
-include Makefile.common
include ../Makefile.inc
+
+PROTOCOL_NAME = h501
+
+EXT_ASN_FILE_LIST =
+
+ASN_FILE_LIST = \
+ H501-MESSAGES.asn
+
+EXTRA_DIST = \
+ $(EXTRA_DIST_COMMON) \
+ $(ASN_FILE_LIST) \
+ packet-$(PROTOCOL_NAME)-template.c \
+ $(PROTOCOL_NAME).cnf
+
+SRC_FILES = \
+ $(EXTRA_DIST) \
+ $(EXT_ASN_FILE_LIST)
+
+A2W_FLAGS =
+
+EXTRA_CNF = \
+ $(builddir)/../h225/h225-exp.cnf \
+ $(builddir)/../h235/h235-exp.cnf
+
+$(builddir)/../h225/h225-exp.cnf:
+ (cd $(builddir)/../h225 && $(MAKE_CNF_EXPORT))
+
+$(builddir)/../h235/h235-exp.cnf:
+ (cd $(builddir)/../h235 && $(MAKE_CNF_EXPORT))