summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index 035ce3982e..8be4d216ce 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -28,6 +28,7 @@ noinst_LIBRARIES = libui.a
CLEANFILES = \
libui.a \
*~
+SUBDIRS = codecs
MAINTAINERCLEANFILES = \
$(GENERATED_FILES) \
@@ -91,6 +92,7 @@ noinst_HEADERS = \
range_utils.h \
recent.h \
rtp_analysis.h \
+ rtp_player.h \
rtp_stream.h \
rtp_stream_dlg.h \
mcast_stream.h \
@@ -111,10 +113,18 @@ noinst_HEADERS = \
webbrowser.h
if USE_GTK2
+if HAVE_LIBPORTAUDIO
+libui_a_SOURCES = \
+ $(WIRESHARK_GTK_SRC) \
+ $(noinst_HEADERS) \
+ $(WIRESHARK_TAP_SRC) \
+ rtp_player.c
+else
libui_a_SOURCES = \
$(WIRESHARK_GTK_SRC) \
$(noinst_HEADERS) \
$(WIRESHARK_TAP_SRC)
+endif
else
libui_a_SOURCES = \
ethclist.c \