summaryrefslogtreecommitdiff
path: root/packaging/wix/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/wix/CMakeLists.txt')
-rw-r--r--packaging/wix/CMakeLists.txt8
1 files changed, 0 insertions, 8 deletions
diff --git a/packaging/wix/CMakeLists.txt b/packaging/wix/CMakeLists.txt
index ed9f035a9c..065e279aa6 100644
--- a/packaging/wix/CMakeLists.txt
+++ b/packaging/wix/CMakeLists.txt
@@ -134,12 +134,6 @@ foreach(_dll ${GLIB2_DLLS} ${CARES_DLL} ${GCRYPT_DLLS} ${GEOIP_DLL}
SET(unique_component ${unique_component} ${_dll})
ENDIF(NOT "${unique_component}" MATCHES "(^|;)${_dll}(;|$)")
endforeach()
-file(APPEND "${_all_manifest_wix}" " <Component Id=\"cmpGSpawn_${WIRESHARK_TARGET_PLATFORM}_helper_exe\" Guid=\"*\">\n")
-file(APPEND "${_all_manifest_wix}" " <File Id=\"filSpawn_${WIRESHARK_TARGET_PLATFORM}_helper_exe\" KeyPath=\"yes\" Source=\"$(var.Staging.Dir)\\gspawn-${WIRESHARK_TARGET_PLATFORM}-helper.exe\"/>\n")
-file(APPEND "${_all_manifest_wix}" " </Component>\n")
-file(APPEND "${_all_manifest_wix}" " <Component Id=\"cmpGSpawn_${WIRESHARK_TARGET_PLATFORM}_helper_console_exe\" Guid=\"*\">\n")
-file(APPEND "${_all_manifest_wix}" " <File Id=\"filSpawn_${WIRESHARK_TARGET_PLATFORM}_helper_console_exe\" KeyPath=\"yes\" Source=\"$(var.Staging.Dir)\\gspawn-${WIRESHARK_TARGET_PLATFORM}-helper-console.exe\"/>\n")
-file(APPEND "${_all_manifest_wix}" " </Component>\n")
foreach(_script "init.lua" "console.lua" "dtd_gen.lua")
STRING(REGEX REPLACE "[-|\\.]" "_" _wix_name ${_script})
file(APPEND "${_all_manifest_wix}" " <Component Id=\"cmp${_wix_name}\" Guid=\"*\">\n")
@@ -162,8 +156,6 @@ foreach(_dll ${GLIB2_DLLS} ${CARES_DLL} ${GCRYPT_DLLS} ${GEOIP_DLL}
SET(unique_file ${unique_file} ${_dll})
ENDIF(NOT "${unique_file}" MATCHES "(^|;)${_dll}(;|$)")
endforeach()
-file(APPEND "${_all_manifest_wix}" " <ComponentRef Id=\"cmpGSpawn_${WIRESHARK_TARGET_PLATFORM}_helper_exe\" />\n")
-file(APPEND "${_all_manifest_wix}" " <ComponentRef Id=\"cmpGSpawn_${WIRESHARK_TARGET_PLATFORM}_helper_console_exe\" />\n")
foreach(_script "init.lua" "console.lua" "dtd_gen.lua")
STRING(REGEX REPLACE "[-|\\.]" "_" _wix_name ${_script})
file(APPEND "${_all_manifest_wix}" " <ComponentRef Id=\"cmp${_wix_name}\" />\n")