summaryrefslogtreecommitdiff
path: root/plugins/docsis/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/docsis/Makefile.am')
-rw-r--r--plugins/docsis/Makefile.am68
1 files changed, 64 insertions, 4 deletions
diff --git a/plugins/docsis/Makefile.am b/plugins/docsis/Makefile.am
index 39cda1e095..4bae2791c1 100644
--- a/plugins/docsis/Makefile.am
+++ b/plugins/docsis/Makefile.am
@@ -1,5 +1,4 @@
# Makefile.am
-# Automake file for DOCSIS plugin
#
# Wireshark - Network traffic analyzer
# By Gerald Combs <gerald@wireshark.org>
@@ -18,12 +17,74 @@
# You should have received a copy of the GNU General Public License
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-#
-include Makefile.common
include $(top_srcdir)/Makefile.am.inc
include ../Makefile.am.inc
+# the name of the plugin
+PLUGIN_NAME = docsis
+
+# Non-generated sources to be scanned for registration routines
+NONGENERATED_REGISTER_C_FILES = \
+ packet-bintrngreq.c \
+ packet-bpkmattr.c \
+ packet-bpkmreq.c \
+ packet-bpkmrsp.c \
+ packet-cmctrlreq.c \
+ packet-cmctrlrsp.c \
+ packet-cmstatus.c \
+ packet-intrngreq.c \
+ packet-dbcreq.c \
+ packet-dbcrsp.c \
+ packet-dbcack.c \
+ packet-dccack.c \
+ packet-dccreq.c \
+ packet-dccrsp.c \
+ packet-dcd.c \
+ packet-dpvreq.c \
+ packet-dpvrsp.c \
+ packet-docsis.c \
+ packet-dsaack.c \
+ packet-dsareq.c \
+ packet-dsarsp.c \
+ packet-dscack.c \
+ packet-dscreq.c \
+ packet-dscrsp.c \
+ packet-dsdreq.c \
+ packet-dsdrsp.c \
+ packet-macmgmt.c \
+ packet-map.c \
+ packet-mdd.c \
+ packet-ocd.c \
+ packet-regack.c \
+ packet-regreq.c \
+ packet-regreqmp.c \
+ packet-regrsp.c \
+ packet-regrspmp.c \
+ packet-rngreq.c \
+ packet-rngrsp.c \
+ packet-sync.c \
+ packet-tlv.c \
+ packet-tlv-cmctrl.c \
+ packet-type29ucd.c \
+ packet-type35ucd.c \
+ packet-uccreq.c \
+ packet-uccrsp.c \
+ packet-ucd.c \
+ packet-vendor.c
+
+# Non-generated sources
+NONGENERATED_C_FILES = \
+ $(NONGENERATED_REGISTER_C_FILES)
+
+# Headers.
+CLEAN_HEADER_FILES = \
+ packet-tlv.h
+
+HEADER_FILES = \
+ $(FLEX_GENERATED_HEADER_FILES) \
+ $(CLEAN_HEADER_FILES)
+
plugin_LTLIBRARIES = docsis.la
docsis_la_SOURCES = \
@@ -47,7 +108,6 @@ MAINTAINERCLEANFILES = \
plugin.c
EXTRA_DIST = \
- Makefile.common \
plugin.rc.in \
README \
CMakeLists.txt