summaryrefslogtreecommitdiff
path: root/plugins/irda/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/irda/Makefile.am')
-rw-r--r--plugins/irda/Makefile.am24
1 files changed, 20 insertions, 4 deletions
diff --git a/plugins/irda/Makefile.am b/plugins/irda/Makefile.am
index f9a11d5d47..afbec5f504 100644
--- a/plugins/irda/Makefile.am
+++ b/plugins/irda/Makefile.am
@@ -1,5 +1,4 @@
# Makefile.am
-# Automake file for IrDA plugin
#
# Wireshark - Network traffic analyzer
# By Gerald Combs <gerald@wireshark.org>
@@ -18,12 +17,30 @@
# You should have received a copy of the GNU General Public License
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-#
-include Makefile.common
include $(top_srcdir)/Makefile.am.inc
include ../Makefile.am.inc
+# the name of the plugin
+PLUGIN_NAME = irda
+
+# Non-generated sources to be scanned for registration routines
+NONGENERATED_REGISTER_C_FILES = \
+ packet-ircomm.c \
+ packet-irda.c \
+ packet-sir.c
+
+# Non-generated sources
+NONGENERATED_C_FILES = \
+ $(NONGENERATED_REGISTER_C_FILES)
+
+# Headers.
+CLEAN_HEADER_FILES = \
+ irda-appl.h
+
+HEADER_FILES = \
+ $(CLEAN_HEADER_FILES)
+
plugin_LTLIBRARIES = irda.la
irda_la_SOURCES = \
@@ -53,6 +70,5 @@ MAINTAINERCLEANFILES = \
plugin.c
EXTRA_DIST = \
- Makefile.common \
plugin.rc.in \
CMakeLists.txt