summaryrefslogtreecommitdiff
path: root/plugins/irda/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/irda/Makefile.am')
-rw-r--r--plugins/irda/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/plugins/irda/Makefile.am b/plugins/irda/Makefile.am
index f83062f2d8..5af7e9cf2a 100644
--- a/plugins/irda/Makefile.am
+++ b/plugins/irda/Makefile.am
@@ -70,11 +70,11 @@ LIBS =
# pass only the first few names in the list to the shell, for some
# reason.
#
-# Therefore, we have a script to generate the plugin.c file.
-# The shell script runs slowly, as multiple greps and seds are run
-# for each input file; this is especially slow on Windows. Therefore,
-# if Python is present (as indicated by PYTHON being defined), we run
-# a faster Python script to do that work instead.
+# Therefore, we use a script to generate the register.c file.
+# There are two versions of the script, a shell and a Python version.
+# The Python script runs faster, since it uses caching to speed up
+# repeated runs and doesn't invoke external processes, so we prefer
+# that if Python is available.
#
# The first argument is the directory in which the source files live.
# The second argument is "plugin", to indicate that we should build