summaryrefslogtreecommitdiff
path: root/plugins/opcua/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/opcua/Makefile.am')
-rw-r--r--plugins/opcua/Makefile.am45
1 files changed, 41 insertions, 4 deletions
diff --git a/plugins/opcua/Makefile.am b/plugins/opcua/Makefile.am
index 94279a1788..391635319c 100644
--- a/plugins/opcua/Makefile.am
+++ b/plugins/opcua/Makefile.am
@@ -1,5 +1,4 @@
# Makefile.am
-# Automake file for OpcUa plugin
#
# Adapted by Gerhard Gappmeier for OpcUa
# Wireshark - Network traffic analyzer
@@ -19,12 +18,51 @@
# You should have received a copy of the GNU General Public License
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-#
-include Makefile.common
include $(top_srcdir)/Makefile.am.inc
include ../Makefile.am.inc
+# the name of the plugin
+PLUGIN_NAME = opcua
+
+# Non-generated sources to be scanned for registration routines
+NONGENERATED_REGISTER_C_FILES = \
+ opcua.c
+
+# Non-generated sources
+NONGENERATED_C_FILES = \
+ $(NONGENERATED_REGISTER_C_FILES) \
+ opcua_transport_layer.c \
+ opcua_security_layer.c \
+ opcua_application_layer.c \
+ opcua_serviceparser.c \
+ opcua_complextypeparser.c \
+ opcua_enumparser.c \
+ opcua_simpletypes.c \
+ opcua_servicetable.c \
+ opcua_extensionobjecttable.c \
+ opcua_hfindeces.c \
+ opcua_statuscode.c
+
+# Headers.
+CLEAN_HEADER_FILES = \
+ opcua_complextypeparser.h \
+ opcua_enumparser.h \
+ opcua_hfindeces.h \
+ opcua_statuscode.h \
+ opcua_identifiers.h \
+ opcua_serviceparser.h \
+ opcua_simpletypes.h \
+ opcua_servicetable.h \
+ opcua_application_layer.h \
+ opcua_security_layer.h \
+ opcua_transport_layer.h \
+ opcua_extensionobjectids.h \
+ opcua_serviceids.h
+
+HEADER_FILES = \
+ $(CLEAN_HEADER_FILES)
+
plugin_LTLIBRARIES = opcua.la
opcua_la_SOURCES = \
@@ -48,7 +86,6 @@ MAINTAINERCLEANFILES = \
plugin.c
EXTRA_DIST = \
- Makefile.common \
plugin.rc.in \
README \
CMakeLists.txt