summaryrefslogtreecommitdiff
path: root/plugins/profinet/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/profinet/Makefile.am')
-rw-r--r--plugins/profinet/Makefile.am32
1 files changed, 28 insertions, 4 deletions
diff --git a/plugins/profinet/Makefile.am b/plugins/profinet/Makefile.am
index e650ce0bbe..b48d696bb5 100644
--- a/plugins/profinet/Makefile.am
+++ b/plugins/profinet/Makefile.am
@@ -1,5 +1,4 @@
# Makefile.am
-# Automake file for PROFINET plugin
#
# Wireshark - Network traffic analyzer
# By Gerald Combs <gerald@wireshark.org>
@@ -18,12 +17,38 @@
# You should have received a copy of the GNU General Public License
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-#
-include Makefile.common
include $(top_srcdir)/Makefile.am.inc
include ../Makefile.am.inc
+# the name of the plugin
+PLUGIN_NAME = profinet
+
+# Non-generated sources to be scanned for registration routines
+NONGENERATED_REGISTER_C_FILES = \
+ packet-dcerpc-pn-io.c \
+ packet-dcom-cba.c \
+ packet-dcom-cba-acco.c \
+ packet-pn-dcp.c \
+ packet-pn-mrp.c \
+ packet-pn-mrrt.c \
+ packet-pn-ptcp.c \
+ packet-pn-rt.c \
+ packet-pn-rtc-one.c
+
+# Non-generated sources
+NONGENERATED_C_FILES = \
+ $(NONGENERATED_REGISTER_C_FILES) \
+ packet-pn.c
+
+# Headers.
+CLEAN_HEADER_FILES = \
+ packet-dcom-cba-acco.h \
+ packet-pn.h
+
+HEADER_FILES = \
+ $(CLEAN_HEADER_FILES)
+
plugin_LTLIBRARIES = profinet.la
profinet_la_SOURCES = \
@@ -47,6 +72,5 @@ MAINTAINERCLEANFILES = \
plugin.c
EXTRA_DIST = \
- Makefile.common \
plugin.rc.in \
CMakeLists.txt