summaryrefslogtreecommitdiff
path: root/plugins/unistim/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/unistim/Makefile.am')
-rw-r--r--plugins/unistim/Makefile.am32
1 files changed, 27 insertions, 5 deletions
diff --git a/plugins/unistim/Makefile.am b/plugins/unistim/Makefile.am
index 2664f724db..df5f4d7e36 100644
--- a/plugins/unistim/Makefile.am
+++ b/plugins/unistim/Makefile.am
@@ -1,6 +1,4 @@
# Makefile.am
-# Automake file for Nortel Unistim plugin
-# Copyright 2007, Don Newton <dnewton@cypresscom.net>
#
# Wireshark - Network traffic analyzer
# By Gerald Combs <gerald@wireshark.org>
@@ -19,12 +17,37 @@
# You should have received a copy of the GNU General Public License
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-#
-include Makefile.common
include $(top_srcdir)/Makefile.am.inc
include ../Makefile.am.inc
+# the name of the plugin
+PLUGIN_NAME = unistim
+
+# Non-generated sources to be scanned for registration routines
+NONGENERATED_REGISTER_C_FILES = \
+ packet-unistim.c
+
+# Non-generated sources
+NONGENERATED_C_FILES = \
+ $(NONGENERATED_REGISTER_C_FILES)
+
+# Headers.
+CLEAN_HEADER_FILES = \
+ audio.h \
+ basic.h \
+ broadcast.h \
+ defines.h \
+ display.h \
+ expansion.h \
+ key.h \
+ network.h \
+ uftp.h \
+ packet-unistim.h
+
+HEADER_FILES = \
+ $(CLEAN_HEADER_FILES)
+
plugin_LTLIBRARIES = unistim.la
unistim_la_SOURCES = \
@@ -48,6 +71,5 @@ MAINTAINERCLEANFILES = \
plugin.c
EXTRA_DIST = \
- Makefile.common \
plugin.rc.in \
CMakeLists.txt