summaryrefslogtreecommitdiff
path: root/plugins/wimaxasncp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/wimaxasncp/CMakeLists.txt')
-rw-r--r--plugins/wimaxasncp/CMakeLists.txt43
1 files changed, 3 insertions, 40 deletions
diff --git a/plugins/wimaxasncp/CMakeLists.txt b/plugins/wimaxasncp/CMakeLists.txt
index 96d2a98e99..6e16beb786 100644
--- a/plugins/wimaxasncp/CMakeLists.txt
+++ b/plugins/wimaxasncp/CMakeLists.txt
@@ -19,29 +19,10 @@
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
#
-# Create the Windows .rc file for the plugin.
-# The values come from several files in the source, I can't see how to reuse them
+include(WiresharkPlugin)
# This info is from moduleinfo.nmake
-set(PACKAGE wimaxasncp)
-set(MODULE_VERSION_MAJOR 0)
-set(MODULE_VERSION_MINOR 0)
-set(MODULE_VERSION_MICRO 1)
-set(MODULE_VERSION_EXTRA 0)
-set(MODULE_VERSION "${MODULE_VERSION_MAJOR}.${MODULE_VERSION_MINOR}.${MODULE_VERSION_MICRO}.${MODULE_VERSION_EXTRA}")
-set(RC_MODULE_VERSION "${MODULE_VERSION_MAJOR},${MODULE_VERSION_MINOR},${MODULE_VERSION_MICRO},${MODULE_VERSION_EXTRA}")
-
-# This info is from Makefile.common
-set(PLUGIN_NAME ${PACKAGE})
-
-# This info is from config.nmake
-set(MSVC_VARIANT "${CMAKE_GENERATOR}")
-
-# The rc.in requires a plain VERSION variable
-set(VERSION ${PROJECT_VERSION})
-
-# Create the plugin.rc file from the template
-configure_file(plugin.rc.in plugin.rc @ONLY)
+set_module_info(wimaxasncp 0 0 1 0)
set(DISSECTOR_SRC
packet-wimaxasncp.c
@@ -75,28 +56,10 @@ register_dissector_files(plugin.c
${DISSECTOR_SRC}
)
-add_library(wimaxasncp ${LINK_MODE_MODULE}
- ${PLUGIN_FILES}
- ${CMAKE_CURRENT_BINARY_DIR}/plugin.rc
-)
-
-set_target_properties(wimaxasncp PROPERTIES
- PREFIX ""
- LINK_FLAGS "${WS_LINK_FLAGS}"
- FOLDER "Plugins"
-)
-
-if(ENABLE_APPLICATION_BUNDLE)
- set_target_properties(wimaxasncp PROPERTIES
- LIBRARY_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/run/Wireshark.app/Contents/PlugIns/wireshark
- )
-endif()
-
-target_link_libraries(wimaxasncp epan)
+add_plugin_library(wimaxasncp)
install(TARGETS wimaxasncp
LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION} NAMELINK_SKIP
RUNTIME DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
)
-