summaryrefslogtreecommitdiff
path: root/plugins/wimaxasncp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/wimaxasncp/Makefile.am')
-rw-r--r--plugins/wimaxasncp/Makefile.am32
1 files changed, 28 insertions, 4 deletions
diff --git a/plugins/wimaxasncp/Makefile.am b/plugins/wimaxasncp/Makefile.am
index 8aa916d36e..d86ca72aa8 100644
--- a/plugins/wimaxasncp/Makefile.am
+++ b/plugins/wimaxasncp/Makefile.am
@@ -1,5 +1,4 @@
# Makefile.am
-# Automake file for wimaxasncp plugin
#
# Wireshark - Network traffic analyzer
# By Gerald Combs <gerald@wireshark.org>
@@ -18,12 +17,38 @@
# You should have received a copy of the GNU General Public License
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-#
-include Makefile.common
include $(top_srcdir)/Makefile.am.inc
include ../Makefile.am.inc
+# the name of the plugin
+PLUGIN_NAME = wimaxasncp
+
+#
+# Files generated by Flex.
+#
+FLEX_GENERATED_C_FILES = \
+ wimaxasncp_dict.c
+
+FLEX_GENERATED_HEADER_FILES = \
+ wimaxasncp_dict_lex.h
+
+# Non-generated sources to be scanned for registration routines
+NONGENERATED_REGISTER_C_FILES = \
+ packet-wimaxasncp.c
+
+# Non-generated sources
+NONGENERATED_C_FILES = \
+ $(NONGENERATED_REGISTER_C_FILES)
+
+# Headers.
+CLEAN_HEADER_FILES = \
+ wimaxasncp_dict.h
+
+HEADER_FILES = \
+ $(FLEX_GENERATED_HEADER_FILES) \
+ $(CLEAN_HEADER_FILES)
+
#
# XXX - how to make this apply only to clean files?
#
@@ -60,7 +85,6 @@ MAINTAINERCLEANFILES = \
plugin.c
EXTRA_DIST = \
- Makefile.common \
plugin.rc.in \
wimaxasncp_dict.l \
CMakeLists.txt