summaryrefslogtreecommitdiff
path: root/plugins/wimaxmacphy/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/wimaxmacphy/Makefile.am')
-rw-r--r--plugins/wimaxmacphy/Makefile.am22
1 files changed, 18 insertions, 4 deletions
diff --git a/plugins/wimaxmacphy/Makefile.am b/plugins/wimaxmacphy/Makefile.am
index d7b7360395..c4d79a08ce 100644
--- a/plugins/wimaxmacphy/Makefile.am
+++ b/plugins/wimaxmacphy/Makefile.am
@@ -1,5 +1,4 @@
# Makefile.am
-# Automake file for wimaxmacphy plugin
#
# Wireshark - Network traffic analyzer
# By Gerald Combs <gerald@wireshark.org>
@@ -18,12 +17,28 @@
# You should have received a copy of the GNU General Public License
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-#
-include Makefile.common
include $(top_srcdir)/Makefile.am.inc
include ../Makefile.am.inc
+# the name of the plugin
+PLUGIN_NAME = wimaxmacphy
+
+# Non-generated sources to be scanned for registration routines
+NONGENERATED_REGISTER_C_FILES = \
+ packet-wimaxmacphy.c
+
+# Non-generated sources
+NONGENERATED_C_FILES = \
+ $(NONGENERATED_REGISTER_C_FILES)
+
+# Headers.
+CLEAN_HEADER_FILES = \
+ packet-wimaxmacphy.h
+
+HEADER_FILES = \
+ $(CLEAN_HEADER_FILES)
+
plugin_LTLIBRARIES = wimaxmacphy.la
wimaxmacphy_la_SOURCES = \
@@ -47,6 +62,5 @@ MAINTAINERCLEANFILES = \
plugin.c
EXTRA_DIST = \
- Makefile.common \
plugin.rc.in \
CMakeLists.txt