summaryrefslogtreecommitdiff
path: root/ui/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ui/Makefile.am')
-rw-r--r--ui/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/ui/Makefile.am b/ui/Makefile.am
index 58166e1812..0a698a60df 100644
--- a/ui/Makefile.am
+++ b/ui/Makefile.am
@@ -161,6 +161,14 @@ EXTRA_DIST = \
BUILT_SOURCES = $(GENERATED_HEADER_FILES)
+#
+# This is used to build dumpcap, and dumpcap is, if possible, built as
+# a position-independent executable (for address space layout randomization,
+# as it might be running with extra privileges), so this library needs
+# to be built that way as well.
+#
+libui_a_CFLAGS = $(AM_CFLAGS) $(PIE_CFLAGS)
+
CLEANFILES = \
doxygen-ui.tag \
libui.a \