summaryrefslogtreecommitdiff
path: root/ui/cli/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ui/cli/Makefile.am')
-rw-r--r--ui/cli/Makefile.am81
1 files changed, 65 insertions, 16 deletions
diff --git a/ui/cli/Makefile.am b/ui/cli/Makefile.am
index 8140d3850b..e5414985e4 100644
--- a/ui/cli/Makefile.am
+++ b/ui/cli/Makefile.am
@@ -19,7 +19,6 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-include Makefile.common
include $(top_srcdir)/Makefile.am.inc
AM_CPPFLAGS = $(INCLUDEDIRS) $(WS_CPPFLAGS) $(GLIB_CFLAGS) \
@@ -27,6 +26,70 @@ AM_CPPFLAGS = $(INCLUDEDIRS) $(WS_CPPFLAGS) $(GLIB_CFLAGS) \
noinst_LIBRARIES = libcliui.a
+# Generated header files that we want in the distribution.
+GENERATED_HEADER_FILES =
+
+# Generated C source files that we want in the distribution.
+GENERATED_C_FILES = \
+ tshark-tap-register.c
+
+# All the generated files.
+GENERATED_FILES = \
+ $(GENERATED_HEADER_FILES) \
+ $(GENERATED_C_FILES)
+
+# Files that generate compileable files
+GENERATOR_FILES =
+
+# sources for TShark taps
+TSHARK_TAP_SRC = \
+ tap-camelsrt.c \
+ tap-comparestat.c \
+ tap-diameter-avp.c \
+ tap-endpoints.c \
+ tap-expert.c \
+ tap-follow.c \
+ tap-funnel.c \
+ tap-gsm_astat.c \
+ tap-hosts.c \
+ tap-httpstat.c \
+ tap-icmpstat.c \
+ tap-icmpv6stat.c \
+ tap-iostat.c \
+ tap-iousers.c \
+ tap-macltestat.c \
+ tap-protocolinfo.c \
+ tap-protohierstat.c \
+ tap-rlcltestat.c \
+ tap-rpcprogs.c \
+ tap-rtd.c \
+ tap-rtp.c \
+ tap-rtspstat.c \
+ tap-sctpchunkstat.c \
+ tap-simple_stattable.c \
+ tap-sipstat.c \
+ tap-smbsids.c \
+ tap-srt.c \
+ tap-stats_tree.c \
+ tap-sv.c \
+ tap-wspstat.c
+
+noinst_HEADERS = \
+ tshark-tap.h
+
+# All sources that should be put in the source distribution tarball
+libcliui_a_SOURCES = \
+ $(TSHARK_TAP_SRC) \
+ $(noinst_HEADERS) \
+ $(GENERATED_HEADER_FILES) \
+ $(GENERATED_C_FILES)
+
+libcliui_a_DEPENDENCIES =
+
+EXTRA_DIST = \
+ .editorconfig \
+ $(GENERATOR_FILES)
+
CLEANFILES = \
libcliui.a \
tshark-tap-register.c-tmp \
@@ -51,19 +114,10 @@ MAINTAINERCLEANFILES = \
# The first argument is the directory in which the source files live.
# All subsequent arguments are the files to scan.
#
-tshark-tap-register.c: $(TSHARK_TAP_SRC) Makefile.common $(top_srcdir)/tools/make-tap-reg.py
+tshark-tap-register.c: $(TSHARK_TAP_SRC) $(top_srcdir)/tools/make-tap-reg.py
@echo Making tshark-tap-register.c
@$(PYTHON) $(top_srcdir)/tools/make-tap-reg.py $(srcdir) tshark-taps $(TSHARK_TAP_SRC)
-# All sources that should be put in the source distribution tarball
-libcliui_a_SOURCES = \
- $(TSHARK_TAP_SRC) \
- $(noinst_HEADERS) \
- $(GENERATED_HEADER_FILES) \
- $(GENERATED_C_FILES)
-
-libcliui_a_DEPENDENCIES =
-
doxygen:
if HAVE_DOXYGEN
$(DOXYGEN) doxygen.cfg
@@ -72,8 +126,3 @@ endif # HAVE_DOXYGEN
checkapi:
$(PERL) $(top_srcdir)/tools/checkAPIs.pl -build \
-sourcedir=$(srcdir) $(TSHARK_TAP_SRC)
-
-EXTRA_DIST = \
- .editorconfig \
- $(GENERATOR_FILES) \
- Makefile.common