summaryrefslogtreecommitdiff
path: root/ui/qt/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'ui/qt/CMakeLists.txt')
-rw-r--r--ui/qt/CMakeLists.txt12
1 files changed, 5 insertions, 7 deletions
diff --git a/ui/qt/CMakeLists.txt b/ui/qt/CMakeLists.txt
index 5d7d06a223..84a2b44e1b 100644
--- a/ui/qt/CMakeLists.txt
+++ b/ui/qt/CMakeLists.txt
@@ -508,13 +508,11 @@ add_custom_target(
)
set_target_properties(translations PROPERTIES FOLDER "UI")
-if (WERROR_COMMON_FLAGS)
- set_source_files_properties(
- ${WIRESHARK_QT_FILES}
- PROPERTIES
- COMPILE_FLAGS ${WERROR_COMMON_FLAGS}
- )
-endif()
+set_source_files_properties(
+ ${WIRESHARK_QT_FILES}
+ PROPERTIES
+ COMPILE_FLAGS "${WERROR_COMMON_FLAGS}"
+)
add_definitions(${QT_DEFINITIONS})