summaryrefslogtreecommitdiff
path: root/wsutil/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'wsutil/CMakeLists.txt')
-rw-r--r--wsutil/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/wsutil/CMakeLists.txt b/wsutil/CMakeLists.txt
index a7f0663ead..05b32815c1 100644
--- a/wsutil/CMakeLists.txt
+++ b/wsutil/CMakeLists.txt
@@ -38,6 +38,12 @@ if(HAVE_SSE4_2)
)
endif()
+if(NOT HAVE_POPCOUNT)
+ set( WSUTIL_POPCOUNT_FILES
+ popcount.c
+ )
+endif()
+
set(WSUTIL_FILES
adler32.c
aes.c
@@ -89,6 +95,7 @@ set(WSUTIL_FILES
ws_version_info.c
${WSUTIL_PLATFORM_FILES}
${WSUTIL_SSE42_FILES}
+ ${WSUTIL_POPCOUNT_FILES}
)
if(APPLE)