summaryrefslogtreecommitdiff
path: root/wsutil/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'wsutil/CMakeLists.txt')
-rw-r--r--wsutil/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/wsutil/CMakeLists.txt b/wsutil/CMakeLists.txt
index 24e35f50e7..e90b487f56 100644
--- a/wsutil/CMakeLists.txt
+++ b/wsutil/CMakeLists.txt
@@ -63,6 +63,10 @@ add_library(wsutil ${LINK_MODE_LIB}
set(FULL_SO_VERSION "0.0.0")
+set_target_properties(wsutil PROPERTIES COMPILE_DEFINITIONS "WS_BUILD_DLL")
+if(DEFINED COMPILE_HIDE_SYMBOLS)
+ set_target_properties(wsutil PROPERTIES COMPILE_FLAGS ${COMPILE_HIDE_SYMBOLS})
+endif()
set_target_properties(wsutil PROPERTIES LINK_FLAGS "${WS_LINK_FLAGS}")
set_target_properties(wsutil PROPERTIES VERSION ${FULL_SO_VERSION} SOVERSION 0)
@@ -79,7 +83,7 @@ configure_file(../abi-descriptor.template abi-descriptor.xml)
file(GLOB HEADERS *.h)
file(MAKE_DIRECTORY abi-check-headers)
-file(COPY ${HEADERS} DESTINATION abi-check-headers)
+file(COPY ${HEADERS} ../ws_symbol_export.h DESTINATION abi-check-headers)
add_custom_command(OUTPUT libwsutil.abi.tar.gz
COMMAND cp ../config.h abi-check-headers/