summaryrefslogtreecommitdiff
path: root/wsutil/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'wsutil/CMakeLists.txt')
-rw-r--r--wsutil/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/wsutil/CMakeLists.txt b/wsutil/CMakeLists.txt
index d8870fe041..fd3eb6a745 100644
--- a/wsutil/CMakeLists.txt
+++ b/wsutil/CMakeLists.txt
@@ -36,7 +36,6 @@ set(WSUTIL_FILES
base64.c
bitswap.c
buffer.c
- cfutils.c
clopts_common.c
cmdarg_err.c
copyright_info.c
@@ -78,6 +77,10 @@ set(WSUTIL_FILES
${WSUTIL_PLATFORM_FILES}
)
+if(HAVE_OS_X_FRAMEWORKS)
+ set(WSUTIL_FILES ${WSUTIL_FILES} cfutils.c)
+endif()
+
#
# XXX - we're assuming MSVC doesn't require a flag to enable SSE 4.2
# support, and that, if the compiler supports a flag for SSE 4.2