summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2009-05-05 13:21:07 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2009-05-06 21:44:30 -0700
commit245871145e6a12739ed8d4512b5e2cb6b1a1721c (patch)
tree6a04e9714fbacccdc4273cd1836e376f0f7f3b6b /Makefile.am
parentbc32bb55ca5a9059dec9d9326f34ff372b54f154 (diff)
downloadxscope-245871145e6a12739ed8d4512b5e2cb6b1a1721c.tar.gz
Use XORG_CWARNFLAGS, XORG_CHANGELOG, & XORG_WITH_LINT
Signed-off-by: Alan Coopersmith <alan.coopersmith@sun.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 16 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 8564c50..ef3d731 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,5 @@
#
-# Copyright 2008 Sun Microsystems, Inc. All rights reserved.
+# Copyright 2008-2009 Sun Microsystems, Inc. All rights reserved.
# Use subject to license terms.
#
# Permission is hereby granted, free of charge, to any person obtaining a
@@ -30,7 +30,7 @@
bin_PROGRAMS = xscope
-AM_CFLAGS = $(XSCOPE_CFLAGS)
+AM_CFLAGS = $(CWARNFLAGS) $(XSCOPE_CFLAGS)
xscope_LDADD = $(XSCOPE_LIBS)
xscope_SOURCES = \
@@ -84,7 +84,7 @@ MAINTAINERCLEANFILES = ChangeLog
.PHONY: ChangeLog
ChangeLog:
- (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+ $(CHANGELOG_CMD)
dist-hook: ChangeLog
@@ -111,3 +111,16 @@ SUFFIXES = .$(APP_MAN_SUFFIX) .man
.man.$(APP_MAN_SUFFIX):
sed $(MAN_SUBSTS) < $< > $@
+
+if LINT
+# Check source code with tools like lint & sparse
+
+ALL_LINT_FLAGS=$(LINT_FLAGS) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
+ $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS)
+
+lint: $(BUILT_SOURCES)
+ @for f in $(xscope_SOURCES) ; do \
+ case $$f in *.c) \
+ $(LINT) $(ALL_LINT_FLAGS) $(srcdir)/$$f ;; esac ; \
+ done
+endif LINT