summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2011-01-07 19:49:26 -0800
committerAlan Coopersmith <alan.coopersmith@oracle.com>2011-01-07 19:49:26 -0800
commite71c788fe1659e58a983d7a388367317a23e07a9 (patch)
treef5e10b3a56868768cfec73a2fa24c2c77106764f /configure.ac
parente1c92233d401c7a6e739220de8d5260abc1a445a (diff)
downloadxscope-e71c788fe1659e58a983d7a388367317a23e07a9.tar.gz
config: replace deprecated AM_CONFIG_HEADER with AC_CONFIG_HEADERS
Regroup AC statements under the Autoconf initialization section. Regroup AM statements under the Automake initialization section. Add missing AC_CONFIG_SRCDIR Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index df770f1..ca8fdd7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -22,14 +22,17 @@ dnl DEALINGS IN THE SOFTWARE.
dnl
dnl Process this file with autoconf to create configure.
+# Initialize Autoconf
AC_PREREQ([2.60])
AC_INIT([xscope], [1.3],
[https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], [xscope])
+AC_CONFIG_SRCDIR([Makefile.am])
+AC_CONFIG_HEADERS([config.h])
+
+# Initialize Automake
AM_INIT_AUTOMAKE([foreign dist-bzip2])
AM_MAINTAINER_MODE
-AM_CONFIG_HEADER(config.h)
-
# Require X.Org macros 1.8 or later for MAN_SUBSTS set by XORG_MANPAGE_SECTIONS
m4_ifndef([XORG_MACROS_VERSION],
[m4_fatal([must install xorg-macros 1.8 or later before running autoconf/autogen])])