summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBenedikt Morbach <benedikt.morbach@googlemail.com>2013-03-09 14:33:52 +0100
committerBastien Nocera <hadess@hadess.net>2013-10-21 10:29:48 +0200
commita30ad0beaef1d6c42742c21c4f6c11866e9f53c9 (patch)
tree9db28d6624567acf8b88bd04b99a1d119b63caea /configure.ac
parentcf5d24922ed3634af8a7a3def998c14600f8dff3 (diff)
downloadupower-a30ad0beaef1d6c42742c21c4f6c11866e9f53c9.tar.gz
build: Fix --without-systemdunitdir / --without-systemdutildir
would take the with_*=no as a value and try to install to a "no" directory https://bugs.freedesktop.org/show_bug.cgi?id=62060
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 8 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index d0d6476..af41082 100644
--- a/configure.ac
+++ b/configure.ac
@@ -166,15 +166,19 @@ AC_ARG_WITH([systemdutildir],
AS_HELP_STRING([--with-systemdutildir=DIR], [Directory for systemd utilities]),
[],
[with_systemdutildir=$($PKG_CONFIG --variable=systemdutildir systemd)])
-AC_SUBST([systemdutildir], [$with_systemdutildir])
-AM_CONDITIONAL(HAVE_SYSTEMDUTILDIR, [test -n "$with_systemdutildir"])
+if test x$with_systemdutildir != xno; then
+ AC_SUBST([systemdutildir], [$with_systemdutildir])
+fi
+AM_CONDITIONAL(HAVE_SYSTEMDUTILDIR, [test -n "$systemdutildir"])
AC_ARG_WITH([systemdsystemunitdir],
AS_HELP_STRING([--with-systemdsystemunitdir=DIR], [Directory for systemd service files]),
[],
[with_systemdsystemunitdir=$($PKG_CONFIG --variable=systemdsystemunitdir systemd)])
-AC_SUBST([systemdsystemunitdir], [$with_systemdsystemunitdir])
-AM_CONDITIONAL(HAVE_SYSTEMDSYSTEMUNITDIR, [test -n "$with_systemdsystemunitdir"])
+if test x$with_systemdsystemunitdir != xno; then
+ AC_SUBST([systemdsystemunitdir], [$with_systemdsystemunitdir])
+fi
+AM_CONDITIONAL(HAVE_SYSTEMDSYSTEMUNITDIR, [test -n "$systemdsystemunitdir"])
dnl ---------------------------------------------------------------------------
dnl - Compile time default choice of backend