summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLandry Breuil <landry@rhaalovely.net>2011-02-26 14:17:09 +0100
committerRichard Hughes <richard@hughsie.com>2011-03-21 18:38:49 +0000
commitad04d9fd4489bd1f710c0ff7a06389a9a6216da7 (patch)
treeb3ada10f44593f244384825fc0c36e279f3512a9 /configure.ac
parent2527d0170d1f5c01e402d90af318854db2f70422 (diff)
downloadupower-ad04d9fd4489bd1f710c0ff7a06389a9a6216da7.tar.gz
Add openbsd backend switches
Signed-off-by: Richard Hughes <richard@hughsie.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 83f315a..540bc9a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -174,13 +174,15 @@ dnl - Compile time default choice of backend
dnl ---------------------------------------------------------------------------
AC_ARG_WITH([backend],
AS_HELP_STRING([--with-backend=<option>],
- [Default backend to use linux, freebsd, dummy (dummy)]))
+ [Default backend to use linux, freebsd, openbsd, dummy (dummy)]))
# default to a sane option
if test x$with_backend = x; then
if test -e /usr/include/gudev-1.0/gudev/gudev.h ; then
with_backend=linux
elif test -e /usr/include/dev/acpica/acpiio.h ; then
with_backend=freebsd
+ elif test -e /usr/include/machine/apmvar.h ; then
+ with_backend=openbsd
else
with_backend=dummy
fi
@@ -208,6 +210,7 @@ AM_CONDITIONAL(HAVE_IDEVICE, [test x$have_idevice = xyes])
AM_CONDITIONAL(BACKEND_TYPE_DUMMY, [test x$with_backend = xdummy])
AM_CONDITIONAL(BACKEND_TYPE_LINUX, [test x$with_backend = xlinux])
AM_CONDITIONAL(BACKEND_TYPE_FREEBSD, [test x$with_backend = xfreebsd])
+AM_CONDITIONAL(BACKEND_TYPE_OPENBSD, [test x$with_backend = xopenbsd])
dnl ---------------------------------------------------------------------------
dnl - Build self tests
@@ -233,6 +236,7 @@ etc/Makefile
src/Makefile
src/dummy/Makefile
src/freebsd/Makefile
+src/openbsd/Makefile
src/linux/Makefile
tools/Makefile
doc/Makefile