summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorDavid Zeuthen <davidz@redhat.com>2008-05-08 22:29:38 -0400
committerDavid Zeuthen <davidz@redhat.com>2008-05-08 22:29:38 -0400
commit37f9df9b0568f9834452c949336783bf34e02ab9 (patch)
tree567a010da3aa10870c7f52f1c311a5e36bc9cc0f /doc/Makefile.am
downloadupower-37f9df9b0568f9834452c949336783bf34e02ab9.tar.gz
initial commit
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am81
1 files changed, 81 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
new file mode 100644
index 0000000..9953167
--- /dev/null
+++ b/doc/Makefile.am
@@ -0,0 +1,81 @@
+
+SUBDIRS = man dbus
+
+NULL =
+
+AUTOMAKE_OPTIONS = 1.7
+
+# The name of the module.
+DOC_MODULE=devkit-power
+
+# The top-level SGML file.
+DOC_MAIN_SGML_FILE=devkit-power-docs.xml
+
+# Extra options to supply to gtkdoc-scan
+SCAN_OPTIONS=--ignore-headers=config.h
+
+# The directory containing the source code. Relative to $(srcdir)
+DOC_SOURCE_DIR=../policy
+
+# Used for dependencies
+HFILE_GLOB=
+#$(top_srcdir)/policy/*.h
+CFILE_GLOB=
+#$(top_srcdir)/policy/*.c
+
+# Headers to ignore
+IGNORE_HFILES= \
+ $(NULL)
+
+# CFLAGS and LDFLAGS for compiling scan program. Only needed
+# if $(DOC_MODULE).types is non-empty.
+INCLUDES = \
+ $(DBUS_GLIB_CFLAGS) \
+ $(GLIB_CFLAGS) \
+ -I$(top_srcdir)/policy \
+ -I$(top_builddir)/policy \
+ $(NULL)
+
+GTKDOC_LIBS = \
+ $(DBUS_GLIB_LIBS) \
+ $(NULL)
+
+# Extra options to supply to gtkdoc-mkdb
+MKDB_OPTIONS=--sgml-mode --output-format=xml
+
+# Extra options to supply to gtkdoc-mktmpl
+MKTMPL_OPTIONS=
+
+# Non-autogenerated SGML files to be included in $(DOC_MAIN_SGML_FILE)
+content_files = \
+ version.xml \
+ man/devkit-power.xml \
+ man/devkit-power-daemon.xml \
+ man/DeviceKit-power.xml \
+ dbus/org.freedesktop.DeviceKit.Power.ref.xml \
+ dbus/org.freedesktop.DeviceKit.Power.Source.ref.xml \
+ $(NULL)
+
+# Images to copy into HTML directory
+HTML_IMAGES = \
+ $(NULL)
+
+# Extra options to supply to gtkdoc-fixref
+FIXXREF_OPTIONS=
+
+MAINTAINERCLEANFILES = \
+ *~ \
+ Makefile.in \
+ devkit-power.types \
+ devkit-power-*.txt \
+ $(NULL)
+
+if ENABLE_GTK_DOC
+include $(top_srcdir)/gtk-doc.make
+else
+EXTRA_DIST =
+endif
+
+# Version information for marking the documentation
+EXTRA_DIST += version.xml.in
+