summaryrefslogtreecommitdiff
path: root/doc/man/Makefile.am
diff options
context:
space:
mode:
authorDavid Zeuthen <davidz@redhat.com>2008-05-08 22:29:38 -0400
committerDavid Zeuthen <davidz@redhat.com>2008-05-08 22:29:38 -0400
commit37f9df9b0568f9834452c949336783bf34e02ab9 (patch)
tree567a010da3aa10870c7f52f1c311a5e36bc9cc0f /doc/man/Makefile.am
downloadupower-37f9df9b0568f9834452c949336783bf34e02ab9.tar.gz
initial commit
Diffstat (limited to 'doc/man/Makefile.am')
-rw-r--r--doc/man/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/doc/man/Makefile.am b/doc/man/Makefile.am
new file mode 100644
index 0000000..f49dde9
--- /dev/null
+++ b/doc/man/Makefile.am
@@ -0,0 +1,24 @@
+
+NULL =
+
+if MAN_PAGES_ENABLED
+
+man_MANS = \
+ devkit-power.1 \
+ devkit-power-daemon.8 \
+ DeviceKit-power.7 \
+ $(NULL)
+
+%.1 %.7 %.8 : %.xml
+ $(XSLTPROC) -nonet http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl $<
+
+endif # MAN_PAGES_ENABLED
+
+EXTRA_DIST= \
+ devkit-power.xml \
+ devkit-power-daemon.xml \
+ DeviceKit-power.xml \
+ $(NULL)
+
+clean-local:
+ rm -f *~ *.[178]