summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorRichard Hughes <richard@hughsie.com>2009-07-27 16:40:11 +0100
committerRichard Hughes <richard@hughsie.com>2009-07-27 16:40:11 +0100
commit0c8d29a90f5b5b7d84ec834213ac7e4390e89db9 (patch)
tree913239be76d6075d7926c8cd1252060ca9dc170f /src/Makefile.am
parent8cf5c058c337a114d6fc5cf18593c5ecf1099efd (diff)
downloadupower-0c8d29a90f5b5b7d84ec834213ac7e4390e89db9.tar.gz
Initial split to make DeviceKit-power compile without GUdev for non-linux platforms
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 2 insertions, 6 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5e1c754..71e7d0f 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -19,6 +19,7 @@ INCLUDES = \
-DEGG_CONSOLE="\"DKP_CONSOLE\"" \
-I$(top_srcdir)/devkit-power-gobject \
-I$(top_srcdir) \
+ -I$(top_srcdir)/src/dummy -I$(top_builddir)/src/dummy \
$(GIO_CFLAGS) \
$(DBUS_GLIB_CFLAGS) \
$(GUDEV_CFLAGS) \
@@ -69,15 +70,9 @@ devkit_power_daemon_SOURCES = \
dkp-daemon.h dkp-daemon.c \
dkp-device.h dkp-device.c \
dkp-device-list.h dkp-device-list.c \
- dkp-device-supply.h dkp-device-supply.c \
- dkp-device-csr.h dkp-device-csr.c \
- dkp-device-wup.h dkp-device-wup.c \
- dkp-device-hid.h dkp-device-hid.c \
- dkp-input.h dkp-input.c \
dkp-qos.h dkp-qos.c \
dkp-wakeups.h dkp-wakeups.c \
dkp-history.h dkp-history.c \
- sysfs-utils.h sysfs-utils.c \
dkp-main.c \
$(BUILT_SOURCES)
@@ -89,6 +84,7 @@ devkit_power_daemon_CPPFLAGS = \
devkit_power_daemon_LDADD = \
-lm \
+ dummy/libdkpshared.a \
$(USB_LIBS) \
$(GIO_LIBS) \
$(DBUS_GLIB_LIBS) \