summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorEric Koegel <eric.koegel@gmail.com>2014-07-14 08:16:06 +0300
committerRichard Hughes <richard@hughsie.com>2014-07-14 19:34:46 +0100
commit9a2b2633095fb901fc1931ab0c600392d68bb3b4 (patch)
treebb4c1ff39c34b1547fe0d000dbb2c27e3bb8af26 /src/Makefile.am
parentd1bb06985fb30a9dfd4c2eb423ac19540445b9e4 (diff)
downloadupower-9a2b2633095fb901fc1931ab0c600392d68bb3b4.tar.gz
Remove polkit dependency
With the removal of the suspend/hibernate code, there's no longer a need for upower to depend on polkit. This patch removes the old polkit code. Signed-off-by: Richard Hughes <richard@hughsie.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 0 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 7ef0ca5..2de5e6d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -21,7 +21,6 @@ AM_CPPFLAGS = \
$(GIO_CFLAGS) \
$(DBUS_GLIB_CFLAGS) \
$(GUDEV_CFLAGS) \
- $(POLKIT_CFLAGS) \
$(GLIB_CFLAGS)
UPOWER_LIBS = $(top_builddir)/libupower-glib/libupower-glib.la
@@ -62,8 +61,6 @@ dbusif_DATA = \
org.freedesktop.UPower.Wakeups.xml
upowerd_SOURCES = \
- up-polkit.h \
- up-polkit.c \
up-daemon.h \
up-daemon.c \
up-device.h \
@@ -92,7 +89,6 @@ upowerd_LDADD = \
$(USB_LIBS) \
$(GIO_LIBS) \
$(DBUS_GLIB_LIBS) \
- $(POLKIT_LIBS) \
$(UPOWER_LIBS)
if BACKEND_TYPE_DUMMY